Vertical collapse on Storage System portable PC

I recently stumbled across a junked ‘Picollo’ portable PC made by Storage System Inc. This unit had a 66MHz 486 Overdrive processor and 10″ Sony Trinitron SVGA display and no doubt cost a fortune in its time.

Unfortunately the chassis had been partly gutted, missing the outer case and a variety of parts. The 10″ monitor still appeared to be salvageable however so I gave it a try.

After connecting everything as it appeared to go I connected a PC and powered on the display. Sadly the it was completely collapsed vertically, although I could make out enough detail in the thin line that appeared to be sure that it was otherwise functional.

The deflection is handled by the board mounted on top of the CRT. After fixing loads of dry joints around the horizontal output stage I decided to focus efforts around the vertical deflection stage.

This is based around an ST TDA1675A IC. I grabbed the datasheet for the IC and discovered that the circuit in the display was quite similar to the test circuit shown in the data sheet. The scope confirmed that the sync input was working, as well as the ramp generator. Unfortunately there was no output.

Google searching for the IC revealed many forum posts identifying this as a common cause of failure, and that it was also sensitive to failed components elsewhere in the vertical deflection circuit. Many people suggested replacing all of the surrounding capacitors and diodes as well as the IC just as a precaution.

TradeTech listed the IC as being on back order which was not ideal. In the mean time I though it would be worth attacking the other likely culprits in case the IC was still OK.

I replaced all of the electrolytics in the vertical stage as a matter of course but it didn’t fix the problem. I also identified a Zener diode (ZD201) with the marking ‘4A3’. After some research I found that this is in fact an HZ4A3, a 3.7V Zener. The closest I could get was a 3.6V 1N4729 so fitted one just in case. No difference.

There was also a standard 1N4004 rectifier diode (D207) mounted under the heatsink. I replaced this and it immediately fixed the problem! The weird part is that the diode appeared to check OK out of the circuit.

The horizontal yoke connector also had some discolouration on the plug due to heating because of a bad connection. I cleaned up the pins in the connector the the PCB header before reassembling it.

So now I have a dinky vintage 10″ Sony Trinitron SVGA display and just need to find a use for it! 🙂

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: